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1 Getting Started

1.1 Introduction

WS-Engineer Plug-in For LTSA Eclipse

The LTSA WS-Engineer plug-in is an extension to the LTSA Eclipse Plug-in which allows service
models to be described by translation of the service process descriptions, and can be used to
perform model-based engineering including:

e Supportfor BPEL4AWS 1.1, WS-CDL 1.0 and WSIF (Web Service Invocation
Framework) Loganalysis.

¢ Analysisofinteractionmodels for specified properties (e.g. trace equivalence, deadlock,
livenessetc)

¢ Synthesisof compositionand choreography interaction processes from behaviour models
¢ Verfication of service behaviour models (e.g. for partner obligations)

¢ Validationthrough interactive andanimated models

e Traceanalysisforservice composition interactionlogs (e.g. BPWS4J Logs)

The WS-Engineer Tool isbased uponthe work by Dr. Howard Foster in hisPhD thesis: A Rigorous
Approach to Engineering Web Service Compositions.

1.2 Installation

This plug-in requires the LTSA Eclipse plug-in, and can be installed as a feature from the main LTSA
Eclipse Update site.

Note: The install site for LTSA Eclipse is: http://www.doc.ic.ac.uk/ltsa/eclipse/install.

e Please see the LTSA Eclipse help guide for details of installing the core LTSA Eclipse and associated
plug-ins (including WS-Engineer).

o Additionally you may want to install some specification language tool sulites.

e There are also some Sample Files which can be used to perform analysis tutorials.

© 2009 Imperial College London
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uk.ic.doc.ltsa.eclipse.UpdateSite

uk.ic.doc.liza.eclipse Feature - 2.0.0

LTSA Eclipse Extensions LTSA Eclipse Extensions

uk.ic.doc.liza.eclipse.arch.Feature - 2.0.0

uk.ic.doc.ltza.eclipse.msc.Feature - 2.0.0

uk.ic.doc.ltza.eclipse. weengineer.Feature - 2.0.0

2 The WS-Engineer Environment

Thissectiondescribesthe WS-Engineer Perspective, WS-Engineer Views and the WS-Engineer
Preferences Page.

2.1 The WS-Engineer Perspective

WS-Engineer provides a pre-configured perspective with suggested views and layout set for use. To
enable the perspective follow the steps below.

1. Locate the Eclipse menu bar. Select Window -> Open Perspective -> Other

Mm Help LTSA

M Window I =R, =

Mew Editor

Open Perspective E ;\Si b—
k

Shiow Yigw

2. Select LTSA WS-Engineer Perspective and click OK. If this menu item is not present, then the
plug-in has not been successfully installed.

© 2009 Imperial College London
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& Open Perspective
N archstudio 4
CVS Repository Explaring
#@*Dehug
aJ Java (default)
g,’ Java Browsing
?,:JJava Type Hierarchy
I""5,,LTS.°. Perspective
=0 Plug-in Development
[bResource
" 50l Explorer
EaTeam Synchronizing
[ [o]4 ] [ Cancel ]
3. Noticethe layoutof views-windows will be similartothatillustrated in the figure below.
= LTSA WS-Engineer Perspective - Eclipse SDK @Elﬂ_hj
File Edit Mavigate Search Project Run  Window Help
%~ Q- Fr Gl o - = =
T2 Naviga 2 = O[] LTS Draw 22 Al LTSAnimatoq =0 %WS-Engineer‘u’iew P LTSInteract\onAnimatoq =0
= 4de4ddAEE X e oo GeHl| D | & &
& | = q:b ! Machine W 1
! LTsA Imperial College
7 LTSA [LTSA/LTSA w B -
> MyBPELProject WS Englneer London
@ Design | 5 Interactlons| ;{J_% Obllgatlons| gﬂ Deployment| !
Select Process, Design and Property for Verification i
Verify | <not ready>: select source for verification
1. Process Source (BPEL/CDL)
<no process source selected> I
2. Design Source (MSC/UML)
BII' |I| <no design source selected>
8= Outlin 52 =08 3. Property
An outline is not - = ) T
vy 4 r? Process (0 Specification il
< | + | Draw AIphabet|Transitions
=0 &P}ob]m\s% ¥ =08
3 errors, 0 warnings, 0 others
Description ° Rescurce
> & Errors (3 items)
Oso =~ T 0
® & M|F
< 3 < 1 +
e
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2.2

The WS-Engineer View

The WS-Engineer view presents the analysis features of the LTSA WS-Engineer tool in a series of tab
pages.

Note: If this view is not visible, enable it by Window - Show View - Other - LTSA WS-Engineer
- WS-Engineer View.

%WS-EngineerView & = 0

D% &

Al Lrsa | ial Coll
J_j_l] WS-Engineer L'Eﬁﬁ'; OReSe

% Design | 45 Interactions | 4 Obligations ¢l Deployment | [42] Modes

Select Process, Design and Property for Verification

Verify | <not ready>: select source for verification

1. Process Source (BPEL/CDL)

& Browse | <no process source selecteds

m

2. Design Source (MSC/UML)

B Browse | <no design source selected>

3. Property

EY Switch | @ Process (7 Specification

I

<

Show Mappings

The design view can be accessed by selecting the & Design 12 on the WS-Engineer view tab list.

The interactions view can be accessed by selecting the & Interactions (5 on the WS-Engineer view
tab list.

The obligations view can be accessed by selecting the 22 Obligations| (ap on the WS-Engineer view
tab list.

The deployment view can be accessed by selecting the ¥ Depleyment (a4 on the WS-Engineer view
tab list.

The modes view can be accessed by selecting the 4l Medes  tah on the WS-Engineer view tab list.

© 2009 Imperial College London
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2.3 WS-Engineer Preferences

The WS-Engineer preferences page isaccessed from the Eclipse menuitem: Window >
Preferences - LTSA WS-Engineer.

General

These options apply to commen functions of W5-Engineer,

Auto show trace from results (Open MSC Editor)

| Hide non-chservable actions (empty, silent etc)

Interactions
These options apply to interaction checking of W5-Engineer.

| Reduce Port Maps for Processes Mot Included
| Set Port Maps As Sequences

Obligations
These options apply to cbligation checking of W5-Engineer.

| Use CDL roleType-behavior name for mappings

Restore Defaults | | Apply

Further details of preferences can be found in the Preferences section of this help guide.

3 Tutorials

Thissection detailssome tutorials for using the WS-Engineer plug-in.

3.1 Working with WS-Engineer

WS-Engineer supports a number of WS-* standards and supporting tool sets.

Tool Sets

To make working with WS-Engineer easier, it is recommended to have one or more of the following tools.

View Specification Tools Home Page Eclipse Update
Language Site (if available)

Design, InteractionsWS-BPEL 2.0 Eclipse BPEL Editonwww.eclipse.org/  |download.eclipse.

Obligations and bpel org/technology/bpel/

© 2009 Imperial College London
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View Specification Tools Home Page Eclipse Update
Language Site (if available)

Deployment update-site/
Obligations WS-CDL 1.0 Pi4SOA WS-CDL [sourceforge.net/

Tool Suite projects/pi4dsoa/
Deployment, Modes [xADL 2.0 ArchStudio www.isr.uci.edu/ www.isr.uci.edu/

projects/archstudio/ |projects/archstudio-
update/

Deployment, Modes [UML 2.0 IBM Rational www-01.ibm.com/

3.11

Software Architect

software/awdtools/

architect/
swarchitect/

Sample Files

'“‘-"? Thereare Sample Files which can be used as source files described in this tutorial.

WS-BPEL and Eclipse BPEL Editor

In this tutorial the user will be able to create a new WS-BPEL process and validate the process

through WS-Engineer LTSA Animator.

Note: This tutorial requires the use of the Eclipse BPEL Editor.

1. Create a new BPEL project and BPEL process.

a. From the Eclipse Menus select File > New - Project > BPEL 2.0 > BPEL Project and select

Next.

© 2009 Imperial College London
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Tutorials

= Mew Project E@g

Selectawigard e <>

Create a new BPEL project. [

Wizards:
type filter text
4 (= BPEL2.0 -
1% BPEL Project il

[ Show All Wizards.

|
@ Sk Next > B

b. Name the project (e.g. MyBPELProject) and click Finish.

= New BPEL Project E=EER™

New BPEL Project
Create a new BPEL 2.0 project.

Project name: | MyBPELP rcrjecﬂ

Project contents:
Uze default

Directons | € Mdevieclipsed4rsa\workspace\MyBPELProject | | Browse...

Target Runtirme

| <None> - | [New..|

Configuration

’< custom: v] ’ Madify... l

Net> | [L_Finish ][ Cancel

=3

c. Select the new MyBPELProject project in the Package Explorer View.

© 2009 Imperial College London
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d. Right-click and select New - Other - BPEL 2.0 > New BPEL Process File and select Next.
e. Enter a process name (e.g. MyBPELProcess), a namespace and keep the template as

Asynchronous BPEL Process. Click Finish.

r

-«

n:llEli:?-

Create a BPEL Process File
Create a 2.0 BPEL file.

Process Details

BPEL Process Mame: MyBPELProcess
Mamespace: MyBPELProcess -
Template: ihsynchronous BPEL Process -

.

2. Open the new BPEL Process using the Eclipse BPEL Editor

Note that two activities are included, one receivelnput (to receive a new request and create a new

instance of the process) and callbackClient which invokes the reply.

5 MyBPELProcess.bpel 53 = O
<] | % MyBPELProcess

i fio Partner Links B R

_ client
e @ Variables & X

input

o | receivelnput St

& callbackClient # Correlation Sets = %
#2 Message Exchan... % %

®©

Design | Source

3. Check process "Safety"

© 2009 Imperial College London
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A Safety check provides a default deadlock analysis through the process states.

a. Select a blank area in the process editor view and right-click.
b. Select WS-Engineer - Safety Check.

WS-Engineer P | BY Check Safety
Refactor »| @& CheckProgress
Run As ' 4l  Animate
Debug As Y| S, View FSP
Profile As P

[ BPEL Safety Check Iﬁ

:I Mo viclations found in BPEL compesition.

4. Check process "Progress™
A Progress check provides a default trace through the process states.

a. Select a blank area in the process editor view and right-click.
b. Select WS-Engineer - Progress Check. A view of the process as an MSC trace will be displayed.

W5-Engineer P | Bl Check Safety
Refactor * | (4 CheckProgress
Run As g 4l Animate
Debug As Y|, ViewFSP
Profile &xc T

© 2009 Imperial College London
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Y *Viclation Trace MSC &3

hMsC | process

}}1 = E

mybpelpro... client

1
il

mybpelprocess_ g

mvbpelpmcess_&
+

ient_receive_initiste

ient_invake_onresult

I
M5 Editor | FSP Editor

5. View the Graphical LTS of the Process

a. Select a blank area in the process editor view and right-click.
b. Select WS-Engineer - Animate.
c. Switch the LTS Draw view and you can see the state machine of the main process.

W5-Engineer
Refactor
Run As
Debug As
Profile As

«r| LTS Draw 52 | LTS Animator

I Machine
v| MYBPELPROCESS I

P B Check Safety

| & CheckProgress
g 4‘ Animate

T, View F5P

= O

d4ddAE L X ¢ <o

client client
receive invoke
Initiate onresult
1| 1] F
4 m b | Draw| Alphabet| Transitions

© 2009 Imperial College London
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6. Animate the BPEL process

a. Select a blank area in the process editor view and right-click.
b. Select WS-Engineer - Animate.
c. Switch the LTS Animator view and you can step through the process state machine.

WS-Engineer b B Check Safety
Refactor * | ¢ CheckProgress
Run As " 4l Animate
Debug As " | "%, View FSP
Profile As LA |
Al LTS Animator 57 -0

G & &

mybpelprocess_client_receive_initiate |+
mybpelprocess_client_invoke_onresult |
END =| [ ] mybpelprocess_client_receive_initiate
| [ | mybpelprocess_client_imwoke_onresult
END OF TUTORIAL

3.1.2 WS-BPEL and LTSA-BPEL Editor

In this tutorial the user will be able to import a WS-BPEL process and generate a Finite State
Process composition from the process.

1. Import BPEL4WS files in to a project

a. Locate your WS-BPEL source files and import them in to the project created previously.
b. In this example we use a WS-BPEL process file called "tutoriall.bpel".
C. You can substitute the name of your WS-BPEL files for this one at each step.

2. Open a WS-BPEL file in WS-Engineer

a. Locate a WS-BPEL file (with extension .bpel) in the Navigator view.
b. Select the file, and right-click the mouse, select Open With = LTSA-BPEL Editor, as illustrated
below.

© 2009 Imperial College London
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o
==
=I-[=F Examples :
=== Tukarial_1 ! | Machine
ooz
&
M *
H-T=F Iksa
Qpen
Open With *|® ¥ LTSA-BPEL Editar
- =| Copy Text Editar
0= Outline 52 =l
o ) System Edikar
&n outline is nok availab
i Delete In-Place Editor
Move. ., Defaulk Edikar
Rename

C. This option will open the file as a LTSA BPEL Editor file and display the contents in a new Editor
View, as illustrated below.

X -

<procesz name="FoliceEnquiry™ L

targetiamespace="urn:pito:FoliceEndgu:
¥mlns:thns="urn:pito:PoliceEnquiry™
xmlna="http://schemas.xml3oap.org/ wa,

<warishles>
<wariable name="request"™ messageType="tl
</wvarisbles>

<pARrtners:
<parther name="0fficerbevice™ serwvicelia
<partner name="VehicleEngquiry"™ servicel:
<partner name="NominalEnguiry"™ servicel:
<partner name="InsuranceEncuirv" service™
£ >
BPEL4WS | FSP Editor

1. Note the tabs along the bottom of the BPEL4WS Editor View. The BPEL4WS tab is the main editor
for the BPEL4WS source, whilst the FSP Editor tab can be selected to show a FSP representation

of the BPEL4WS.
2. Click on the FSP Editor tab to list the FSP for the BPEL4WS currently being edited.

© 2009 Imperial College London
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R RPN
/¢ START EBEPEL4WS Process: POLICEENQUIRY
RNy
ff wariable start

range POLICEENQUIRY IntRange = 0..1
POLICEENQUIRY wariable (Ai=0) = POLICEENQUIRY
POLICEENQUIRY wariable[i:POLICEENQUIRY IntRs
POLICEENQUIRY wariable['null] = { write[]:PC

set POLICEENQUIRY varishle ENUM = {a, kb, c}
ENUM POLICEENQUIRY variskle (A='null)] = POLIC
POLICEENQUIRY warisble[i:POLICEENQUIRY wvaris
POLICEENQUIRY wariable['null] = | write[3:PC

A owrariakhle end

£ >
BPEL4%'S |FSP Editor

3. Note that whenever the BPEL4WS source changes, the switch to FSP will update the FSP source
code representing the new BPEL4AWS source. Try to change something in the BPEL4AWS Editor and
switch to see any changes in the FSP.

Compile the LTS

1. Note that the Outline View now contains some elements of the BPEL4WS process. The core
compositions are a _BPELModel and _Instance. The _BPELModel composition represents all
possible trace paths through the BPEL4AWS process, whilst _Instance represents only one (default)
choice.

D; E:g | E
= HH Cornpositions
POLICEEMQUIRY _BPELModel
POLICEENQUIRY Instance

Processes

Properties (property)

+

Properties (assert)
T4 Zonsktants

|| Sets

& Ranges

2. The user can analyse these processes from the WS-BPEL source by using the same approach
described in the LTSA Eclipse help

END OF TUTORIAL

© 2009 Imperial College London
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3.13

WS-CDL and LTSA-WSCDL Editor

In this tutorial the user will be able to import a WS-CDL description and generate a Finite State

Process composition from the description.

1. Import WS-CDL files in to a project

a. Locate your WS-CDL source files and import them in to the project created previously.
b. In this example we use a WS-CDL description called "tutoriall.bpel".
C. You can substitute the name of your WS-CDL files for this one at each step.

2. Open the WS-CDL file in WS-Engineer

N -

below.

- % -
=I-l=F Examples
= Er;':llzarial_l :
il ucori
+-[=F |tsa Hlew '
Qpen
Open YWikh
0= Outline 52 =| Copy
Anoutline is nok availab
¥ CDelete
Mowe,,,
Rename

k|l ® .| TSA-BPEL Editor

. Locate the WS-CDL file (with extension .bpel) in the Navigator view.
. Select the file, and right-click the mouse, select Open With - LTSA-BPEL Editor, as illustrated

= O | | LTS Draw 52

Machine

|Z| Tet Editor

System Edikar
In-Place Editor
Defaulk Editar

3. This option will open the file as a LTSA BPEL Editor file and display the contents in a new Editor

View, as illustrated below.
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X =8
<process name="FPoliceEnquiry"™ s
targetiamespace="urn:pito:FoliceEndgu:
¥mlns:thns="urn:pito:PoliceEngquiry™
¥mlna="http://schemas.xml3oap.org/ wa,

<warishles>
<wvariable name="regquest"™ messageType="t
</variahles:>

<partners:
<partner name="0fficerbewvice®™ serwvicelis
<partner name="VehicleEngquiry"™ servicel:
<partner name="NominalEngquiry™ =serwvicel:

<parthner name="InsuranceEnguiry” service™
£ >

BPEL4%'5S | FSP Editar

4. Note the tabs along the bottom of the BPEL4AWS Editor View. The BPEL4WS tab is the main editor
for the BPEL4WS source, whilst the FSP Editor tab can be selected to show a FSP representation
of the BPEL4AWS.

5. Click on the FSP Editor tab to list the FSP for the BPEL4WS currently being edited.

X =0
s

NN RN

/¢ START EPEL4W3 Process: POLICEENOQUIRY

NN

A wariasble start

range POLICEENQUIRY IntRangs = 0..1

POLICEENQUIRY wariable (A=0) = POLICEENQUIRY

POLICEENQUIRY wariable[i:POLICEENQUIRY IntRe

POLICEENQUIRY wariable['null] = | write[j:PC

set POLICEENQUIRY wvarishle ENUM = {a, b, c}

ENUM POLICEENQUIRY wvarisble (i='null] = POLIC
POLICEENQUIRY wariable[i:POLICEENQUIRY waris
POLICEENQUIRY wariable['null] = [ write[]:PC

A wrariahle end

£ >
BPEL4%W'S | FSP Editor

6. Note that whenever the BPEL4WS source changes, the switch to FSP will update the FSP source
code representing the new BPEL4WS source. Try to change something in the BPEL4WS Editor and
switch to see any changes in the FSP.

END OF TUTORIAL
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3.2 Design Analysis

This section describes various common activities when using the Design Check features in the WS-
Engineer plug-in.

3.2.1 Overview

The design view of WS-Engineer provides verification of WS-BPEL orchestration process against that of
design specifications in the form of UML style sequence charts. We model the interaction sequences
built to support multiple-partner conversations across enterprise domains and with a view of wider goals.
We limit the scope of choreography analysis to that of interactions between compositions.

The design view can be accessed by selecting the & Design 12 on the WS-Engineer view tab list.

?j{é W5-Engineer View &2 ="
Gl D& &
[Uc] WS-Engineer London

% Design | 5 Interactions | %% Obligations | ;4 Deployment | 23] Modes

Select Process, Design and Property for Verification

(% Verify | Ready for verification.

1. Process Source (BPEL/CDL)

Browse | BPEL: MYBPELPROCESS

2. Design Source (MSC/UML)

2 Browse | MSC Specification Loaded.

3. Property

B Switch | @ Process Specification

Show Mappings

m

<«

The essence of this verification is to prove that a property exists in the composition modelling of
combined implementation and design models. Although the task of comparing models is easier in
simple processes, more complex processes require anin-depth and time-consuming comparison. Model
checking can then be performed to formally test that a WS-BPEL implementation provides the
necessary activities to meet the MSC specification, through a model trace. Additionally, the aim is to
provide as much a mechanicalverification as possible, so thatobservation is not required by human eye
inlarger more complex processes.
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You can read more about this type of verification in Chapter 6 of "A Rigorous Approach to
Engineering Web Service Compositions" by Howard Foster Imperial College London.

3.2.2 Preparation

For this tutorial you need to have met several pre-requisites:

1. Created a Design Specification for a Web Service Composition as MSCs using the LTSC-MSC Editor.
2. Created a WS-BPEL process (or obtained an existing WS-BPEL process representing the design
specification created in 1.).

These inputs are required to perform the verification step.

"‘-‘? Thereare Sample Files which can be used as source files described in this tutorial.

3.2.3 Tutorial: Verifying Design and WS-BPEL

In this tutorial the user will be able to analyse a WS-BPEL process for fulfillment of a Design
Specification.

Note: Ensure you have carried out the pre-requisites as described in the Preparation section.

Steps

1. Select the @ Design tab on the WS-Engineer View

2. Add a BPEL process

= B
Click on the button to select the WS-BPEL process, alternatively you can "drag and drop"

the .bpel file on the Design View as shown below.

© 2009 Imperial College London
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- Navigate & - O i:y} Design | £5 Interactions ;__f—- Obligations | . jj Deployment }}1
1-Orchestrations .

coRlEs
55 pito_iterationl.bpel
A8 pito_iteration].bpel.wsc
[¥) pitomsclaxmnl 11 17/06;
(¥} pitomsc2aml 11 17706,

Select Process, Design and Property for Verification

Verify | <not ready>: select source for verification

. (BPEL/CDL)

EPEL: POLICEENQUIRY

2. Design Source (MSC/UML)

25 Browse | <no design source selected»

If the WS-BPEL file is valid, then the name of the BPEL process is shown under the 1. Process Source
section.

m

3. Select the Design Source

_ 2T Browse ) o )
Click on the button to select the Design (MSC) specification, alternatively you can "drag

and drop" the .xml file on the Design View as shown below.

== Navigate - O {}}Design 45 Interactions | 4 Obligations i Deployment )

1-Orchestrations =
Select Process, Design and Property for Verification

CoRBES _ -
43 pito_iterationl.bpel Ready for verification.

@ pito,_iterationl.bpel.
B pito_iterationl.bpel.wsc 1. Process Source (BPEL/CDL)

E’D pitomsc2xml 11 17,708, BPEL: POLICEENQUIRY

m

If the Design file is valid, then "MSC Specification Loaded" is shown under the 2. Design Source
section.

4. Check the property of interest for analysis

B Switch
Click the button select the source property for verification.

o Property as Process uses the WS-BPEL implementation as a property against the design
specification (e.g. does the implementation fulfill the behaviour specified in the design specification).

o Property as Specification uses the MSC Design Specification as a property against the WS-BPEL
implementation (e.g. does the specification exhibit any additional behaviour not specified in the
implementation).

© 2009 Imperial College London
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5. Run the Verify action

v Wer
When both implementation and specification files are correctly loaded, the button will be

enabled. Click the button to start the verification. If the button is not enabled after adding both valid
process and design files, then it is possible that the behaviour mappings between these are not
complete and must be manually assigned.

If there is behaviour found that is not equivalent (a property violation) then the point at which the violation
occurs is shown as a warning.

W5-Engineer Design Check Iﬁ

The result contains a violation at:
!._ policeenquiry_nominalenquiry_invoke_getpersonrecords
h,

| Close PE View Trace

[ il

. WView T N
You can click the button to show the trace to violation as an MSC.

If the implementation and specification are equivalent (according to the property selected) then No
Violations found will be shown.

W5-Engineer Design Check ﬁ

No violations found.

Close

- -

END OF TUTORIAL

3.2.4 Options

© 2009 Imperial College London
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3.24.1

3.25

3.3

3.3.1

Behaviour Mappings

Show or Modify the mappings between Process and Design Specification

WS-Engineer automatically attempts to match behaviour labels from the WS-BPEL implementation and
messages in the Design Specification MSC. However, messages in the Design Specification may not
exactly match depending on the choice of labels by the designer.

You can see the mappings used by selecting

Sh M i .
ow Vappings bar at the bottom of the view.

Hide Mappings S

Map Process Specification it

| policeenquiry_anprenquiry_invoke_getan... policeenquiry.anprenquiry.invoke_getar =

] peliceenquiry_anprenguiry_receive_geta... _ _ Jiry. _|

¥ policeenquiry_dnaenquiry_invoke_getdna pnl!ceenqu!r}r.dngenqulr}r.lnvnke_getdna )
i T T policeenquiry.officerdevice.reply_requestenquin

| peliceenquiry_dnaenquiry_receive_getdna vehicleenquiry.policeenquiry.reply_getvehiclers

vl policeenquiry_insuranceenquiry_invoke_... |nominalenguiry.policeenguiry.reply_getpersonn

| policeenquiry_insuranceenquiry_receive_...  insuranceenquiry.policeenquiny.reply_.. i

The specification mappings can the be selected representing particular actions in the WS-BPEL
process.

You can hide the mappings used by selecting

Hide Mappings bar above the mappings list.

Further Reading

Read the following papers onthe techniques used for designanalysis of web service compositions.

o H.Foster, S.Uchitel,J.Magee, J.Kramer, Model-based Verification of Web Service
Compositions, IEEE Automated Software Engineering (ASE) 2003, Montreal, Canada, 2003.

¢ H.Foster A Rigorous Approachto EngineeringWeb Service Compositions, PhD Thesis, Imperial
College London, January, 2006.

Interactions Analysis

This section describes various common activities when using the Interaction Checking features in the
WS-Engineer plug-in.

Overview

The interactions view of WS-Engineer provides verification of collaborating WS-BPEL orchestration
processes. We model the interaction sequences built to support multiple-partner conversations across
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enterprise domains and with a view of wider goals. We limit the scope of choreography analysis to that
of interactions between compositions.

The interactions view can be accessed by selecting the & Interactions (5 on the WS-Engineer view
tab list.

%WS-EngineerFim & -0

GeE|D| & H

= 0| Lrsa _ Imperial College
Vel WS-Engineer =

% Design | 45 Interactions | 4% Obligations ol Deployment | 2] Modes

Drag and drop Processes and Interfaces and Verify

(4 Verify | Ready for verification (or add more processes).

Processes and Interfaces (BPEL/AWSDL)

Process Source Interface
POLICEEMQUIRY Chdeveclipseirunti..  Chdevieclipse..
YEHICLEEMCUIRY Chdevieclipselrunti.,  Chdevieclipse..

The verification performs a service "port connector" based mapping. The verification ensures that the
interacting partners of the service composition fulfill required interaction behaviour, in the correct
sequence and over the correct channels.

You can read more about this type of verification in Chapter 6 of "A Rigorous Approach to
Engineering Web Service Compositions" by Howard Foster Imperial College London.

3.3.2 Preparation

For this tutorial you need to have met several pre-requisites:

1. Created at least two interacting WS-BPEL processes (or obtained existing WS-BPEL processes).
2. Created at least two WSDL specifications for the interacting processes in 1.

These inputs are required to perform the verification step.

"“’-’n‘? Thereare Sample Files which can be used as source files described in this tutorial.
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3.3.3

Tutorial: Interaction Analysis

In this tutorial the user will be able to analyse interacting WS-BPEL processes for
completeness and correctness of behaviour specified.

Note: Ensure you have carried out the pre-requisites as described in the Preparation section.

The verification performs a service "port connector" based mapping. The verification ensures that the
interacting partners of the service composition fulfill required interaction behaviour, in the correct
sequence and over the correct channels.In a simple example, the two WS-BPEL processes below are
executed out of sequence, as the VehicleEnquiry partner firstly executes a reply and then a receive
(receive should be before the reply).

2 PITO.bpel i3 2 *VehicleEnguiry.bpel 7 N
4 4
— L4
T main T main
o | requestFrom Officer o | replyOutput
<§> GetVehicleRecords o | receivelnput

<Epr> GetPersonRecords

©

<§> GetVehiclelnsuranceRecords
In this tutorial we will analyse these processes, observe the violation and then correct the partner
process to observe correctness.

Steps

AE

1. Select the & Interactions Tap on the WS-Engineer View

2. Select the WS-BPEL and WSDL process pairs to analyse

Drag and drop selected WS-BPEL and WSDL files (together) in the Processes and Interfaces list box of
the interactions view. Repeat this for as many interacting processes as you wish to analyse.

Note: Each WS-BPEL process is paired with one or more WSDL files. In this sample, we associate
one WS-BPEL with one WSDL file.
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= <=th> % Design | 45 Interactions | 4 Obligations i Deployment 1
S PITO.bp Drag and drop Processes and Interfaces and Verify

|5 PITO.bpelex
28 PITO.wedl

‘g VehicleEnquiny
5 VehicleEnquin cesses and Interfaces (BPELAWSDL)

£ VehicleEnquiny Prodess Source Interface
p QUIRY Chdevieclipselrun..  Chdeveclipse..
VEHICLEEMQUIRY Chdevieclipseirun.,,  Chdeveclipse...

wj \eri Ready for verification (or add more processes).
G y p

3. Run the Verify action

i Vern
When two or more processes and WSDL files have been added, the button will be

enabled. Click the button to start the interaction verification.
Note: If the button is not enabled after adding both valid process and WSDL files, then it is possible that
the either of the file types is not valid. Check each file for the correct syntax and form.

In the first case (of the out of sequence partner described previously) the following violation is observed.

W5-Engineer Interactions Check ﬁ

The result contains a violation at:
I_l"'-. policeenquiry_vehicleenquiry_invoke_getvehiclerecords

Close P View Trace

. WView T N
You can click the button to show the trace to violation as an MSC.

Now, change the VehicleEnquiry process to reflect the receive BEFORE the reply (as shown below).

© 2009 Imperial College London
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2 VehicleEnquiry.bpel &2 = 0O

v

T main

o | receivelnput

o2 | replyCutput

©

Design | Source

Repeating the verification step shows that No Violations found.

W35-Engineer Design Check lﬁ

( ) No violations found.

Close

END OF TUTORIAL
3.3.4 Further Reading

Read the following papers onthe techniques used for interaction analysis of web service
compositions.

o H.Foster, S.Uchitel, J.Magee, J.Kramer, Compatibility Verification for Web Service
Choreography, IEEE International Conference on Web Services (ICWS) 2004, San Diego, CA,
July 2004.

¢ H.Foster A Rigorous Approachto EngineeringWeb Service Compositions, PhD Thesis, Imperial
College London, January, 2006.
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3.4  Obligations Analysis

This section describes various common activities when using the Obligations Checking features in the
WS-Engineer plug-in.

3.4.1 Overview

The obligations view of WS-Engineer provides verification of orchestration partners (roles in the form of
WS-BPEL) of a choreography policy (in the form of WS-CDL). The verification provides a mechanism to
check that each partner in the choreography fulfills their obligations as part of a role of the choreography.

The obligations view can be accessed by selecting the 3£ Obligations| (ap on the WS-Engineer view

tab list.
%WS-EngineerUim &3 = O
Goll | O | R 8
=) N Lrsa _ Imperial College
U] WS-Engineer Loﬁdon J

:i:y} Design | 45 Interactions | 4 Obligations . Deployment | 4] Modes

Specify Partner Processes, Chorecgraphy and Property to Verify
Gj Verify | Ready for verification.

1. Partner Process (BPEL)

Role
fib . Y
BPEL: POLICEEMQUIRY POLICEENQUIRY -
2. Chorecgraphy Source (CDL) r
Role

3. Property
B Switch | @ Choreography () Partner

44

Show Mappings

S
3.4.2 Preparation

For this tutorial you need to have met several pre-requisites:

1. Created a service choreography policy in the form of WS-CDL.
2. Created a WS-BPEL process (or obtained an existing WS-BPEL process representing the role of a
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3.4.3

partner in the choreography created in 1.).

These inputs are required to perform the verification step.

'B Thereare Sample Files which can be used as source files described in this tutorial.

Tutorial: Obligations Analysis

In this tutorial the user will be able to analyse partner interactions (in the form of WS-BPEL
processes) against their obligations as part of a service choreography (in the form of WS-CDL).

Note: Ensure you have carried out the pre-requisites as described in the Preparation section.

Steps

1. Select the & Obligatiens| 1oh on the WS-Engineer View

2. Add the Partner Process (WS-BPEL) to the Obligations page

= B
Click on the button to select the WS-BPEL process, alternatively you can "drag and drop"

the .bpel file on the Obligations page as shown below.
If the file is valid the BPEL process name will appear in 1. Partner Process, and a default role will be
added to the Process Role List.

g lnteractions
S PITO.bpel 41
|5 PITC.bpelex1:
28 PITO.wsdl 13
4 VehicleEnguin
| VehicleEnquin
28 VehicleEnquin

- WS-CDL 2. Chorecgraphy Source (CDL)

Verify | <not ready> : specify source files for obligation analysis

artner Process (BPEL)

I Role
BPEL: POLICEEMQUIRY POLICEENQUIRY

m

3. Select the Partner Process Role

Expanding the Role list aside the Partner Process name will list all available roles of this process.
Note: the BPEL process can act as several partner roles. The default is the partner process name.

Role / M
[ Browse | epet: poviceenquRy -

POLICEENQUIRY
2. Choreography Source (CDL) --All or Select Role-- [

1. Partner Pracess (BPEL)

Role -
dal - [ 1 P

© 2009 Imperial College London
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4. Add the Choreography Policy specification (WS-CDL) to the Obligations Page

Browse
Click on the button to select a WS-CDL choreography specification, alternatively you can

"drag and drop" the .cdl file on the Obligations page as shown below.
If the file is valid the CDL choreography name will appear in 2. Choreography source, and a default role

will be selected in the Choreography Role List.

(I R

ﬁ% PoliceEnquiry.cdls
|5} PoliceEnquiry.cdrr

% PeliceEnquiny2.cdl

Chorecgraphy Socurce (COL)

. Role
CDL: OFFICERENQUIRY POLICEENQUIRY

2 Mrmmmrbe

5. Select the Choreography Partner Role

Expanding the Role list aside the Choreography Source name will list all available roles defined in this

choreography.
Note: The default role is chosen by the selection of the Partner Process Role in step 2.

2. Choreography Source (COL)
Role

CDL:ICJFFICEF{Er'dQUIF{"rr ”v

--All or 5elect Role--

m

3. Property ANPRENQUIRY
_ __ DNAENQUIRY
@ Choreography () Par pysuRANCEENQUT
NOMINALENQUI
. OFFICERDEVICE
show Mappings bl
VEHICLEENQUIRY

6. Check the property of interest for analysis

B¥ Switch
Click the button select the source property for verification.

¢ Property as Choreography uses the choreography specification as a property against the partner
process role (e.g. does the implementation fulfill the behaviour specified in the choreography

specification).
e Property as Partner uses the partner process role as a property against the choreography
specification implementation (e.g. does the specification exhibit any additional behaviour for the role

that is not specified in the implementation).

7. Run the Verify action

© 2009 Imperial College London
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3.4.4

+j Ve
When both implementation and choreography files are correctly loaded, the button will be

enabled. Click the button to start the verification. If the button is not enabled after adding both valid
process and choreography files, then it is possible that the behaviour mappings between these are not
complete and must be manually assigned.

If there is behaviour found that is not equivalent (a property violation) then the point at which the violation
occurs is shown as a warning.

W5-Engineer Design Check Iﬁ

The result contains a violation at:
!._ policeenquiry_nominalenquiry_invoke_getpersonrecords
h,

| Close PE View Trace

[

. WView T N
You can click the button to show the trace to violation as an MSC.

If the implementation and specification are equivalent (according to the property selected) then No
Violations found will be shown.

W5-Engineer Design Check @

No violations found.

Close

- "]

END OF TUTORIAL

Options

This section contains additional tasks in Obligations Analysis.
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3.4.5

3.5

3.51

Further Reading

Read the following papers on the techniques used for obligations analysis of web service
compositions.

e H.Foster, S.Uchitel, J.Magee, J.Kramer, Model-Based Analysis of Obligations in Web Service
Choreography, IEEE International Conference on Internet&Web Applicationsand Services
(ICIW) 2006, Guadeloupe, French Caribbean

¢ H.Foster A Rigorous Approachto Engineering Web Service Compositions, PhD Thesis, Imperial
College London, January, 2006.

Deployment Analysis

This section describes various common activities when using the Deployment Checking features in the
WS-Engineer plug-in.

Overview

The deployment view of WS-Engineer provides verification of orchestration partners and properties of
service deployment architectures (such as resource allocations). The verification provides a mechanism
to check that the choice of composition behaviour design, architecture configurations and resource
allocations do not cause undesirable deadlock situations.

© 2009 Imperial College London
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%WS-Engineer‘-ﬁm P = 0O

Goll| D | & &

ofe I ial Coll
J__;_LJ WS- -Engineer L";ﬁﬁ';i College

{}}Design 4% Interactions | 42 Obligations o Deployment | 22] Modes

Select Processes and Architecture for Verification

Ready for verification (or add more processes).

1. Architecture Model (UPL/AD2)

Model
Erowse | xADLZ Model Deployment Package Loaded. DualServlet -

2. Process Source (BPELAWSDL)

Process Source Interface
GSSUBMISSION Chdevieclipse..  Chdedeclipse..
INVOKEDMAREL Chdevieclipse.. Chdedeclipse..

You can read more about this type of verification in the following publication: H.Foster, W.Emmerich,
J.Kramer, J.Magee, D.Rosenblumand S.Uchitel, Model Checking Service Compositions under
Resource Constraints, in Proceedings of the 6th joint meeting of the European Software
Engineering Conference and the ACM SIGSOFT Symposiumonthe Foundations of Software
Engineering (ESEC/FSE), Dubrovnik, Croatia. Sept 2007.

3.5.2 Preparation

For this tutorial you need to have met several pre-requisites:

1. Created one or more XADL2.0 Deployment Models or a UML2 Deployment Diagram specifications.
2. Created one or more WS-BPEL processes and their associated WSDL interface specifications.

The sections of Preparation illustrate how to create these pre-requisites.

Y
_“3} Thereare Sample Files which can be used as source files described in this tutorial.
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3.5.2.1 Create a XxADL2 Service Deployment Architecture

This is an example of how the XADL2 Service Deployment configuration was created for the
Molpak orchestration, for both SingleServet and DualServlet configurations.

o/ Prerequisites

- Plug-in Check List (see install instructions)
o ArchStudio4 (tocreate new xADL2 architecture configurations)

1. Switch to the ArchStudio 4 Perspective
a. Locate the Eclipse menu bar.

. Select Window - Open Perspective > Other.
C. Select ArchStudio 4 and click OK.

6 Open Perspective

o

L Archstudio 4 N

ECYS Repository Exploring [ |

e L >
[ Ok, ] [ Cancel

1. Create a new xADL Architecture Description

a. Select the new project ServiceDeploymentCheck.

b. Select File > New = Other = ArchStudio4 = ArchStudio Architecture Description and click
next.

c. Name the file MolpakXADL and click Finish.

T Mavigator &2 = O
9 g 7
- 1= ServiceDeploymentCheck
5 .project
= MolpakxADL . x<ml

2. Create the Service Deployment Stereotypes

© 2009 Imperial College London
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o0 oTo

. Select the new file MolpakXADL.xml in the project ServiceDeploymentCheck.

. Right-click with mouse, and select Open-With - Archipelago.

. Locate the Outline View, and select the parent item "/ServiceDeploymentCheck/Molpak.XADL",
right-click and select Create Type Set.

. Open the new Types branch and select Component Types.

. Right-click and select New Component Type. Select the [New Component Type] added under
Component Types. Right-click and select Edit Description.

. Type the name as Server.

. Repeat e. and g. for the following Component Types: ServiceOrchestration, Servlet and
ThreadPool.

. Create new Connector Types for: Deployment and Resource.

o Cutiine &2 = O
= @ fServiceDeploymentCheack Molpak
= Statecharts
= Structures
== Types
== Component Types
Server
ServiceOrchestraton
Servlet
ThreadPoo
== Connector Types

= Interface Types

. Create a Single Servlet Deployment Architecture

. Select the Structures branch, right-click and select New Structure.

. Select the [New Structure] item, right-click and edit the description to be SingleServiet.

. Double-click the new SingleServlet structure to open the Archipelago Structure Editor.

. Locate the Component Types branch in the Outline View and drag-and-drop a number of each
type to the Structure Editor. For the molpak example, we need: 2x ServiceOrchestration, 1x
ThreadPool, 1x Servlet, 1x Server, 3x Deployment and 1x Resource.

. For ServiceOrchestration components, right-click and edit the description to the name of each
BPEL In the case of the molpak example, this is one for GSSubmission and one for InvokedMarel.
. On each component and connector, create a New Interface (right-click each instance).

. For ServiceOrchestrations, create a new link between the ServiceOrchestration interfaces and a
Deployment connector interface.

. For the ServiceOrchestration Deployment connectors, create a new link between the Deployment
and the Servlet instance.

i. For the Servlet, create a new link between the Servlet interface and the third Deployment interface

instance. Create a new link between this Deployment instance and the Server interface.

j. For the Servlet, create a second interface and link this to the Resource connector interface.

. Link the Resource connector interface to the ThreadPool interface.
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I. Select the ThreadPool interface object and right-click, select Edit Description and enter "size =
10".

The structure should look like that in the figure below.

1 *MolpakADL.xml - Archipelago &2 = O

GESLBMISSION

LF

4. Create a Dual Servlet Deployment Architecture

a. Select the Structures branch, right-click and select New Structure.

b. Select the [New Structure] item, right-click and edit the description to be DualServlet.

C. Repeat steps a-k in step 5, however, for this configuration we need: 2x ServiceOrchestration, 2x
ThreadPool, 2x Servlet, 1x Server, 3x Deployment and 2x Resource.

d. Link the components and connectors as shown in the figure below.

T *malpak.xml - Archipelago =2 =0

size =5

ThreadPoal

ERSLBMISSION

ThreadPoal2
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3.5.22

a. Set each ThreadPool interface description to be "size = 5".

Create a UML2 Service Deployment Architecture

/' Prerequisites
RSA7.0

¢ |IBM Rational Software Architect 7 (to create new UML2 Deployment Models)

1. Switch to the Modeling Perspective

a. Locate the Eclipse menu bar.
. Select Window - Open Perspective.
C. Select Modeling.

o

Open Perspective
Shiowr Wiew

Customize Perspective...

Save Perspective As..
Reset Ferspactive
Close Perspectve
Close Al Perspectives

LT Tt o o

[E=Y

. Create a new UML Project

. Under Templates select Blank Model.
. Under Filename enter ServiceDeployment.

DO QO 00w

Click Finish to create the new project.

L Project Explorer &2 = ==

=1-1= ServiceDeploy ment
(2 Diagrams
= (22 Models
-2 ServiceDeployment
&) Main
S0 (UMLPrimitiveTypes)

b [ Data
¥ %5 Deblig
&! Java
2 Java Browsing
[k Modeling
il Report Design
Fequirerment

Other ...

. Select File > New > Project - UML Project and click next.
. Enter the name of the project as ServiceDeployment and click next.

. Under Default Diagram type select Deployment Diagram.

2. Import and Apply the Service Deployment Profile

© 2009 Imperial College London


http://www-306.ibm.com/software/awdtools/architect/swarchitect/

Tutorials 39

a. Locate the ServiceDeployProfile example profile (or download from the LTSA Samples page).

b. Select File & Import & General - Existing Projects into Workspace and click next.

€. Under Select root directory, browse to the directory containing the root of the ServiceDeployProfile,
select the directory and click ok.

d. Ensure the ServiceDeployProfile is checked under Projects: and click Finish.

€. In the Navigator View, select the ServiceDeployment Project created in Step 1.

f. Under the Models branch in the project, select the ServiceDeployment, right-click and select UML
Properties from the pop-up context menu.

d. Inthe ServiceDeployment Properties dialog, select the ProfileApplication item (on the list to the
left).

h. Right-click the ProfileApplication table and select Insert New Profile Application.

i. Select the Profile In Workspace option and browse to the ServiceDeployProfile project imported
in a-d. Open the tree and select Profile.epx and click ok and ok again.

j. Select File > Save to update the ServiceDeployment project.

-

;J' ServiceDeployment Properties @

CmedElement ~ | ProfileApplication

Crweniedie mbear

CwnedRule _ | -
OwnedType . context Applied Profile | |
PackagedElement ;::, SerﬂceDeplovment <<ePackages... ®
Packagelmport ;::, SerwceDepIovment «Profie> DefaLlt
FackageMerge .;fi‘.’ SerwceDeponment <Profie= Depl...

il (=it S ServiceDeployment  =Profile= Profile
TemplateBinding < N

(2 Close

3. Create a Single Servlet Deployment Architecture

a. Under the ServiceDeployment Model, select and open the Main diagram.

. Now we need to add some objects to this diagram. Locate the Palette toolbar to the right of the

main diagram window and select the Node drop-down list and select Stereotyped Node.

. Place the new Node on the diagram and select Create <<Servlet>> Node.

. Name the new node object, Servletl.

. Now create a new Stereotyped Node, and select its type as <<Server>>.

Repeat the process for a new Stereotyped Node of type <<ThreadPool>>. Select the new
ThreadPool node and in the Properties view add an attribute named "size" of <Primitive Type>
Integer, and Default Value 10.

g.- Now add two Stereotyped Artifacts, one for each BPEL orchestration. Select the type as
<<ServiceOrchestration>>.

h. Now we need to link the objects. Locate the Palette toolbar to the right of the main diagram window
and select the Manifestation drop-down list and select Deploy. Select the first
ServiceOrchestration node and link it to the Servletl node. Repeat linking the second Service
Orchestration node to the Servletl node.

i. To link the other objects, select the Association relationship in the Palette and link Servletl to the

o

N B e RN o]
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ThreadPool node and Server node.
j- Select File > Save to update the ServiceDeployment project.

#ServiceOrchestraton:

«ThreadPools

InvokeMolpak -resourcel  pacourcel

«deploys —serviet]l msize © Integer

“Servlets 1
F1Servietl
wdeploys
- Servletil :
#ServiceOrchestraton:s 1 _ & et:\fer»

GSSubmission - webserver ) WebServer

N

. Create a Dual Servlet Deployment Architecture

. Under the ServiceDeployment project, select Models, right-click and select Create New Model.
. Click next andunder filename enter ServiceDeployment2. Click Finish to create a new model.

. Now repeat step 3. but add two <<Servlet>> and two <<ThreadPool>> stereotyped nodes.

. Link one orchestration to each Servlet and each Servlet to a ThreadPool.

. Finally link each Servlet to the one WebServer.

. Select File > Save to update the ServiceDeployment project.

O D QO T QO

#ThreadPools

FIResourcel

«deploy» 1 Casize : Integer

: : - resource 1
«ServiceOrchestration:s «Serviets - servletl

35Submission = -
Flservietl 53"1‘"&% sepver

1 woervers
- wehzerydr | WebServer
- zervlet?
i

) : #Servlets
«ServiceCrchestraton: 1

= - Zeryl
InvokeMolpak o et Melonirce 2 ThreadPooks
1 i FIResource?

«deploy» Egsize ; Integer

5. Export the Models for use with WS-Engineer

a. Select File > Export and choose Other > UML XMI Interchange Model and click next.

b. Under Source Models browse and select the ServiceDeployment project, and select the
ServiceDeployment.emx model.

€. Under Destination Directory select a suitable output folder.
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d. Check Recreate IDs and Export applied profiles.

€. Click Finish to export the model in XMI XML format.

f. Repeat a-e for the ServiceDeployment2 model in the same project.

d. Now both of these exported models can be used as input to the Deployment Checking example in
Tutorial 1.

"..";ii' Export
UML XMI Interchange Model
Export model{s) to UML XM Interchange (xmi) format

Source
Models: | /Servicebeployment/Serviceleployment.emx
Destination
Directory: | C
Recreate IDs
[ |Export applied profies

@) Finish l [ Cancel

3.5.3 Tutorial: Deployment Analysis

In this tutorial the user will be able to model-check that WS-BPEL orchestrations are "safe"
given their behaviour and resource constraints specified in a deployment architecture
configuration.

Note: Ensure you have carried out the pre-requisites as described in the Preparation section.

Steps

1. Select the ¥ Deployment Tah on the WS-Engineer View.

2. Select the Deployment Specification File

) [[=] Browse .
Click on the button to select a Deployment Model Package, alternatively you can "drag

and drop" the a XADL2.0 xml file or UML2.0 XMI file on the Deployment View as shown below.
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UmL2
»ADL2

1. Architecture Model (UML/xADZ)

(¥} molpak_xadl2.xm| Z3=E35

3. Select the Deployment Model

2. Process Source (BPEL/WSDIL)

DL2 Model Deployment Package Loaded.

Model
Dualsel

Cmiirrm

L ]

Expanding the Model list aside the Architecture Model will list all available models in the deployment

model package.

Note: The default model is the first model found in the package.

- ' - '

1. Architecture Model (UMLADZ)

Model /

Browse | xADL2 Model Deployment Package Loaded. [Dual.Sen.rlet I'vJ
1

2. Process Source (BPELAWSDL)

| Process

Source Interface

4. Select the WS-BPEL and WSDL process pairs to analyse

DualServlet V

SingleServiet |

Drag and drop selected WS-BPEL and WSDL files (together) in the Process Source list box of the
deployment view. Repeat this for as many interacting processes as you wish to analyse.

Note: Each WS-BPEL process is paired with one or more WSDL files. In this sample, we associate

one WS-BPEL with one WSDL file.

Sy invokedmarel.bpel 2 =
28 invokemolpakservice
UmLZ
v 2

5. Run the Verify action

2. Process Source (BPEL/WSDL)

Process

INVOKEDMAREL

Source

Chdevieclipse...
Chdevieclipse..,

Interface

Chdeveclipse...
Chdevieclipse...

G Verify

When both deployment model and WS-BPEL files are correctly loaded, the - button will be
enabled. Click the button to start the verification.

If there is a violation of the behaviour specified in the WS-BPEL and the deployment configuration
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resources then the point at which the violation occurs is shown as a warning.

W5-Engineer Design Check Iﬁ

The result contains a violation at:
!._ policeenquiry_nominalenquiry_invoke_getpersonrecords
h,

| Close PE View Trace

[ o

. WView T N
You can click the button to show the trace to violation as an MSC.

If there are no violations found then No Violations found will be shown.

W5-Engineer Design Check @

( ) No violations found.

Close

6. Repeat the Verify action for alternative deployment models

END OF TUTORIAL

3.5.4 Further Reading

Read the following papers on the techniques used for obligations analysis of web service
compositions.

e H.Foster, W.Emmerich,J.Kramer,J.Magee, D.Rosenblumand S.Uchitel, Model Checking
Service Compositions under Resource Constraints, inProceedings of ESEC/FSE 2007,
Dubrovnik, Croatia. Sept2007.

¢ H.Foster A Rigorous Approachto Engineering Web Service Compositions, PhD Thesis, Imperial
College London, January, 2006.
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3.6

3.6.1

Modes Analysis

Overview

The modes view of WS-Engineer provides verification of service modes architecture specifications. A
service mode architecture consists of a series of mode service collaborations. Typically this will be
constructed in UML2 (with a Service Modes profile applied). UML2 Component Structure, Constraints,

Activity, Sequence and State Machine Diagrams are translated to formal models and analysed for
consistency and correctness.

& Ws-Engineer View I = g
Gol= DWH| &S| @
LTSA Imperial College

WS-Engineer

i Design |£§- Interactions | & Obligations

London
oA Deployment|:iﬂ Mmdes|
Specification (UML2 Modes Model)

Ready to verify. Current: AutoModes.xmi

Modes Browser

Perspective: Service Regquirements - Convoy - Drive
Service Requirements IS/ IS SN Func|i=§ QoS = ADL
Service Capabilities g
Mada Dentacnle 7| component DriverVehicleUI{ =
Mode: . -

; & /i Service Interfaces 5
Convoy J ) )
Detour B provide Display;

Dlammime

// Service Behaviour

; : %
i DriverVehicleUI = ( init ->
"jpf'q = | - NRIVERVFHICT FLIT AWATTINGDT

Required Services:

You can read more about this type of verification in the following publication(s):

H.Foster, S.Uchitel, J.Kramer, J.Magee, Towards Self-Management in Service-oriented Computing with

Modes , in Proceedings of the Workshop on Engineering Service-Oriented Applications (WESOAOQ7),
Vienna, Austria. Sept 2007.

H.Foster, A.Mukhija, S.Uchitel and D.Rosenblum, A Model-Driven Approach to Dynamic and Adaptive

Service Brokering using Modes, in Proceedings of the 6th International Conference on Service Oriented
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Computing (ICSOC 2008), Sydney, Australia. December 2008.

3.6.2 Preparation
For Service Modes Analysis you need to have met several pre-requisites:
1. Created a Service Mode Model Project.

2. Created one or more Service mode Collaborations
3. Exported the model in UML2 XMI Model format.

The sections of preparation illustrate how to create these pre-requisites.

3.6.2.1 Create a Service Mode Model Project

This is an example of how to create a Service Mode Architecture Model Project. We will use
the Automotive Case Study of the SENSORIA project to illustrate Service Modes and adaptation
requirements.

Note: This example uses the IBM Rational Software Architect 7.5 Standard Edition tool to create a
Service Mode Architecture specification withapplied Service Modes Architectures Profile.

1. In RSA 7.5, switch to the Modeling Perspective

a. Locate the Eclipse menu bar.
. Select Window - Open Perspective - Other.
C. Select Modeling (default).

o

Open Perspective b [ Data
Showr View b | %5 Debug
&! Java
Customize Perspective... = Java Browsing
mawe Ferspective As.. @ MDCJE"FIQ
Reset Perspective {# Report Design
Close Perspectve Requirement
Close Al Perspectives
Other...
kA siaah—m | 3 .
2. Create a new UML Model Project
a. Select File > New > Other > Modeling > Model Project and click next.
b. Enter the name for the project as ServiceModes and click next.
C. Keep new model as "Standard Template" and click next.
d. Under Categories select General.
€. Under Templates select Blank Package.
f. Under the model Filename enter Automotive.
g. Click next to continue.
h. Select Package Type as Model.
i.

Keep the Diagram Type as Freeform Diagram.
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j- Click Finish to create the new project.
k. Notice a new project is visible in the Project Explorer (as show below).

L7 Project Explorer £2 . %5 Mavigator

=a

ER-0

& ServiceModes
(22 Diagrams
(B2 Models
B Automative
[ Main
=7, (UMLPrimitiveTypes)

3. Import and apply the Service Modes Architecture profiles

a. Switch to the Navigator view

b. From Windows Explorer, locate the Service Modes Architecture profile files and drag-and-drop them

on to the ServiceModes project folder in the Navigator view (as shown below)

= =&

(1 e

‘ Crganize =

Mame Date r

0814,
11,

| |ModesProfile.epx
|| QosProfile.epx
[ UML430A_0.9.epx

\%>

18/11,.

@ Modeling - Rational ® Softwar

File Edit Mawvigate Search

E
E

¥~
=8

&

(5 Pro | 55 Maw 23

2 | B

4 [ Servicebdodes
[ .project

ted Autornotive e

ted ModesProfile.epe
ted QoSProfile.sp

d5 UMLASOA,_0.0.epx

=

C. Switch back to the Project Explorer view and select the Automotive model branch
d. Locate the model Properties view and select Profiles.

€. On the view select Add Profile > Profile in Workspace - Browse and select the ModesProfile.

epxunder ServiceModes.

f. Repeat e. adding both QoSProfile.epx and UML4SOA_0.9.epx
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£ Properties 52 . &% Tasks | & Console | L[l Baokmarks ¥ =0

B2 <«Model= Automotive

General Applied Profiles:
Profiles Marme Wersion  Release Label Location
Stereatypes Default 1 7.00 CAProgram |
Dacurnentation Deplayment 1 .00 ChPragram b
Constraints kdodesProfile 25 Civdenrsaly
Capahilities QosProfile 3 Citvdewhrsal
Relationships Standard 1 ChPrograrm |
BAL 450, 10 RALASOR, releas.,  Cidewhrsald
Advanced
L L
|.ﬂ~dd Prafile... Rermowe Profile
4 I 3

g. Switch to the Stereotypes perspective of the model properties.
h. Select Apply Stereotypes select the ModesModel from the ModesProfile profile and click OK.
i. Note that the stereotype is added to the applied stereotypes list.

= Properties £3 . ¥ Tasks | & Console | Ll Bookmarks i

B2 =Model> «ModeModel:» Automotive

General Keywords:

Profiles Applied Stereotypes:

Stereotypes

Documentation Stereotype  Profile Required

; Modebdodel  ModesProfile  False
Constraints

Capahilities

Relationships

Apply Stereatypes.., Unapply Stereotypes
Advanced

4. Save the changes

a. Locate the Eclipse menu bar.
b. Select File > Save All.

3.6.2.2 Create A Service Mode Collaboration

This is an example of how to create a Service Mode Architecture Model Collaboration. We

will use the Automotive Case Study of the SENSORIA project to illustrate Service Modes and
adaptation requirements.
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Please follow the instructions to create a new Service Mode Architecture Model Project if not already
completed.

Note: This example uses the IBM Rational Software Architect 7.5 Standard Edition tool to create a
Service Mode Architecture specification withapplied Service Modes Architectures Profile.

1.

Add a Mode Package

. In Project Explorer, select the ModeModel model (e.g. Automotive) and right-click to show the

context pop-up menu.

. Select Add UML -> Package. A new package branch will be added to the ModeModel in the Project

Explorerview.

. Rename the new package Convoy.
. Switch to the Stereotypes perspective of the model properties.
. Select Apply Stereotypes select the Mode from the ModesProfile profile and click OK.

Note that the stereotype is added to the applied stereotypes list.

. Add a Mode Collaboration

. In Project Explorer, select the Mode Convoy and right-click to show the context pop-up menu.
. Select Add UML -> Collaboration. A new collaboration branch will be added to the Convoy Mode in

the Project Explorer view.

. Rename the new package ConvoyCollaboration.
. Switch to the Stereotypes perspective of the model properties.
. Select Apply Stereotypes select the ModeCollaboration from the ModesProfile profile and click

OK.
Note that the stereotype is added to the applied stereotypes list.

. In Project Explorer, select the ModeCollaboration ConvoyCollaboration and right-click to show the

context pop-up menu.

. Select Add Diagram - Composite Structure Diagram. A new component diagram branch will be

added to the ConvoyCollaboration node in the Project Explorer view.

. Rename the new package ConvoyComposite.
. Import some Components

. Switch to the Navigator view
. From Windows Explorer, locate the Automotive Case Study files and drag-and-drop them on to the

ServiceModes project folder in the Navigator view (as shown below)

© 2009 Imperial College London


http://www-306.ibm.com/software/awdtools/architect/swarchitect/
http://www.doc.ic.ac.uk/ltsa/eclipse/wsengineer/examples.html#models

Tutorials 49

'S (=R
@'-\;_/"?' | < temp . o Mawvigat &3 L5 *Projec | © |
2 &
‘ Organize % @ = ServiceModes
Marne : Date modif j 5l project )
- el Autormotive.ermx
Automotive TS ermx F200% 15 i A .
= - ted AutormotiveCE e
|| OnRoadRepair.em: 18/04,/2008 14 i ModesProfile.epx
- o - t2d OnFoadRepairerm:
ted QoSProfile.epx
2 items selected 9 UML4S0A_0.9,epx

. Switch to the Project Explorer view
. Open the OnRoadAssistance model and navigate to the Vehicle package.
. Select GPS, LocalDiscovery, Orchestrator, Reasoner and Vehicle Communication Gateway
components, right-click and select Copy.
Navigate back to the Mode Convoy package and right-click and select Paste.

. Then back in the OnRoadAssistance model, navigate to the VehicleExternal package and select the
RemoteDiscovery component.

. Copy and paste the RemoteDiscovery component in the Mode Convoy package.

. Now select the Mode Convoy package, and right-click and select Add UML - Component. Name

the new component OtherVehicle.

i- For each component we need to add stereotypes for their service role. We add this by selecting each
component, and in the Properties view adding a stereotype based upon their role. To add a keyword
stereotype, select the component, select Stereotypes and enter the stereotype in the keywords text
box.

k. Stereotype the components added as follows:

«Q ® o0

- =

GPS provider

LocalDiscovery requester, provider
Orchestrator requester, provider
Reasoner requester, provider
Vehicle Communication Gateway requester, provider
RemoteDiscovery requester, provider
OtherVehicle provider

I. Drag and drop each component on to the ConvoyComposite diagram editor.
m.Note now you have some new properties of the ConvoyComposite (for each component added) as
shown below.
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4 0O «Mode= Convay
- & | «providers GPS
- & | erequester, providers LocalDiscovery
- & | erequester, providers Orchestrator
- & | erequester, providers Reasaner
. & ] arequester, providers Wehicle Communication
ks .
| Main
4 "¢ eModeCollaborations ConvoyCollaboration
s .
= ConvoyComposite
g gPs
Cg localDiscavery
[Cg orchestratar
[Cg reasoner
[Cg wehicle Cammunication Gateway

. For visual clarity, add the same stereotypes to each component property.

. Linking Required and Provided Services

. On the ConvoyComposite diagram locate the Palette sidebar and under Composite Structure drop

the list for Provided Interface to select a Required Interface.

. Then move over to the LocalDiscovery component and locate the Port <<service>>

localDiscoverServices. Drop the Required Interface on this port.

. When prompted, choose Select Existing Element and type Location in select an element text box.

Choose the «servicelnterface» Location - Automotive::Convoy::GPS::Location element.

. Now go back to the Palette sidebar and select Connector. Move back to the LocalDiscovery

component and click the port then whilst holding down the left mouse button (to drag the connecting
line) move down to the GPS component and release the connector on the visible port. This binds the
two interfaces together. Name the connector GPSBinding.

. Now proceed to add Ports, Required and Provided Interfaces to the rest of the Composite Structure as

listed in the table below.

From Service To Service To Provided Interface  Connector Name
(new = new port)

Orchestrator LocalDiscoveryService findLocal (new) localBind
Orchestrator Reasoner ServiceSelection reasonserBind
Orchestrator Vehicle Communication AccessExtServices (new) vcgBind

Gateway
Vehicle Communication =~ RemoteDiscovery RemoteServices remoteBind
Gateway
RemoteDiscovery OtherVehicle VCG (new) vcgBinding
4. Create other Mode Packages for "Detour" and "Planning"

. Now repeat steps 1-3 but create one Mode Package for a "Detour" mode composition and one for

"Planning".

. The differences in each package are as follows:
. For the Detour package, replace the OtherVehicle component with a new "HWEmergency"

component. Add suitable ports, interfaces and bindings between the Vehicle Communication
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Gateway and the HWEmergency component.

d. For the Planning package, replace the OtherVehicle component with a new "RoutePlanner”
component. Add suitable ports, interfaces and bindings between the Vehicle Communication
Gateway and the RoutePlanner component.

3.6.2.3 Exporting a Modes Package

This is an example of how to export a UML2 Service Mode Architecture Model to UML XMI
format We use the model created in Create a Service Mode Collaboration section.

Export

a. In Project Explorer, select the <<Mode Model>> Automotive Model and right-click and select
New Folder. Name the folder exported.

. Re-select the <<Mode Model>> Automotive Model and right-click and select Export.

. Select UML 2.1 XMI Interchange Model and click next.

. Select destination as Workspace and browse to the new exported folder under the Model.

. Enable both Recreate IDs and Export applied profiles.
Click Finish to export the model to xmi files.

D Q0T

3.6.3 Tutorial: Modes Analysis

In this tutorial the user will be able to model-check that Service Mode Architectures are "safe"
given their architecture, behaviour and constraints in a service modes architecture
configuration.

Note: Ensure you have carried out the pre-requisites as described in the Preparation section.

THIS TUTORIAL IS STILL UNDER CONSTRUCTION

Steps

1. Select the “ Medes Tap on the WS-Engineer View.

2. Select the Service Modes Specification File

. Browse . .
Click on the button to select a Service Modes Model Package, alternatively you can "drag

and drop" the a UML2 XMl file on the Modes View as shown below. See Exporting a Modes Package
for a sample of how to export a model to UML XMI format.

3.6.4 Further Reading

You can read more about this type of verification in the following publication(s):

H.Foster, S.Uchitel, J.Kramer, J.Magee, Towards Self-Management in Service-oriented Computing with
Modes , in Proceedings of the Workshop on Engineering Service-Oriented Applications (WESOAOQ7),
Vienna, Austria. Sept 2007.

H.Foster, A.Mukhija, S.Uchitel and D.Rosenblum, A Model-Driven Approach to Dynamic and Adaptive
Service Brokering using Modes, in Proceedings of the 6th International Conference on Service Oriented
Computing (ICSOC 2008), Sydney, Australia. December 2008.
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4 Preferences
WS-Engineer includesaseries of preferences pages, accessed from the Eclipse menuitem: Window
- Preferences > LTSA WS-Engineer.
= Preferences @Eli‘]
type filter text LTSA WS-Engineer ~ A
- General - i
. Ant General
. BPEL These options apply to commoen functions of W3-Engineer.
- Data Management
Dino Auto show trace from results (Open MSC Editor)
- Go Diagram /| Hide non-cbservable actions (empty, silent etc)
- Help 2
- Install/Update Interactions E
- Java These options apply to interaction checking of W5-Engineer.
- JavaScript
LTSA : | Reduce Port Maps for Processes Mot Included
4 LT5A WS-Engineer -
WS-BPEL Set Port Maps As Sequences
WS-CDL
- Plug-in Developme Obligations
- Run/Debug These options apply to cbligation checking of W5-Engineer.
- Server
Cervice Policies i | Use COL roleType-behavior name for mappings 1
] 1 I
)] [ QK l | Cancel
Preferencesare splitinto General WS-Engineer verification preferences (appliestoactions taken in
the WS-Engineer view), WS-BPEL preferences (appliesto the translation of WS-BPEL processes
inthe Eclipse environmentand LTSA-WSBPEL Editor) and WS-CDL preferences (appliestothe
translation of WS-CDL choreography specifications).
4.1 WS-Engineer Preferences

The WS-Engineer preferences page isaccessed fromthe Eclipse menuitem: Window >
Preferences > LTSA WS-Engineer.
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General

These options apply to cornmon functions of W3-Engineer.

Auto show trace from results (Open MSC Editor)

| Hide non-chservable actions (empty, silent etc)

Interactions

These options apply to interaction checking of W5-Engineer,

| Reduce Port Maps for Processes Mot Included

| Set Port Maps As Sequences

Obligations

These options apply to obligation checking of W5-Engineer.

o Use COL roleType-behavior name for mappings

General

Option

| Restore Defaults| | Apply

Description

Auto show trace from results (Open MSC Editor) This option specifieswhether the defaultaction of

Hide non-observable actions (empty, silentetc)

Interactions

Option
Reduce Port Maps for Processes Not Included

verificationisto openamessage sequencetracein
the LTSA-MSC editor. If checked, theeditor
will be opened. If unchecked, amessage boxwill
openandthenthe userisgivenachoice of
whether to show the trace.
Thisoptionspecifieswhether WS-Engineer hides
any non-observable actions in service process
(WS-BPEL) or choreography descriptions. If
checked, theactionsare hidden. Ifunchecked,
theactionsare observable in verification.

Description
Thisoption specifiesthatany partner process port

mappingsnotfoundininteraction checkingare
reduced to the observable actions of the client
process only. If checked, theinteraction
checkingwill reduce the ports. If unchecked, the
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4.2

Option Description
full portmapping (invoke, receive, reply) will be
created.

Set Port Maps as Sequences Thisoptionspecifieswhether WS-Engineer builds

a portmappingasaparallel compositionorasa

sequence ofactions. If checked, theactionsare
builtinsequence. If unchecked, theactionsare
builtasaparallel composition.

Obligations
Option Description

Use CDL roleType-behaviour name for mappings This options specifiesthatthe CDL roleType-
behaviour name isusedto link the name ofa
partnerinaCDL choreography specification with
a WS-BPEL partinerLinkrolename. If
checked, the CDL roletypeisused. If
unchecked, the WS-BPEL process name isused
to link between CDL and WS-BPEL.

WS-BPEL Preferences

The WS-Engineer WS-BPEL preferences page isaccessed from the Eclipse menu item: Window >
Preferences - LTSA WS-Engineer > WS-BPEL.

General
These options apply to general functions of W3-EPEL in W5-Engineer,

Hide <empty> actions
| Hide condition .write actions
Hide condition .read actions
| Hide throw actions

| Assurmne Output Variable Only Invokes as Rendezvous

| Restore Defaults| | Apply
General
Option Description
Hide <empty>actions Thisoption specifies whether the empty construct

of WS-BPEL ishiddenintranslation. If checked
, theempty actionishidden. If unchecked, the
emptyactionsare includedinthe observable
actions.
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Option Description
Hide condition.write actions Thisoption specifieswhether the write actions of

conditional constructs of WS-BPEL are hiddenin
translation. If checked, the writeactionsare
hidden. If unchecked, theactionsareincludedin
the observable actions.

Hide condition.read actions Thisoptionspecifieswhether the read actions of
conditional constructs of WS-BPEL are hiddenin
translation. If checked, the read actionsare
hidden. If unchecked, theactionsareincludedin
the observable actions.

Hide throwactions Thisoptionspecifieswhether the throw actions of
WS-BPEL are hiddenintranslation. If checked,
the throwactionsare hidden. If unchecked, the
throwactionsare included inthe observable

actions.
Assume Output Variable Only Invokes as ThisoptionspecifiesthatifthereisonlyaOutput
Rendezvous Variable specifiedinan Invokeactionthenthe

defaultmappingistobuildarendezvous (invoke,
invoke-receive) portmodel. If checked, the
mapping buildsa rendezvous model (invoke >
invoke_receive). If unchecked, themappings
buildsaasynchronous mapping (invoke > receive).

4.3 WS-CDL Preferences

The WS-Engineer WS-CDL preferences page isaccessed fromthe Eclipse menuitem: Window >
Preferences > LTSA WS-Engineer > WS-CDL.

General
These options apply to general functions of W5-CDL in WS-Engineer.

o Ignere invalid interactions on restricted channel type actions
Hide «<silent> actions
| Hide condition .write actions

| Hide causeException (throw) actions

| Restore Defaults| | Apply
General
Option Description
Hide <silent>actions Thisoption specifieswhether the silent construct

of WS-CDL ishiddenintranslation. If checked,
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5.1

Option

Hide condition .write actions

Hide causeException (throw) actions

Ignoreinvalidinteractionsonrestricted channel

typeactions

Appendix

Short cuts

Description
thesilentactionishidden. If unchecked, thesilent

actionsareincludedinthe observableactions.
Thisoption specifieswhether the write actions of
conditional constructs of WS-CDL are hiddenin
translation. If checked, thewriteactionsare
hidden. If unchecked, theactionsareincludedin
the observableactions.

Thisoption specifieswhether the causeException
actionsof WS-CDL are hiddenintranslation. If
checked, the causeExceptionactionsare hidden.
If unchecked, the causeExceptionactionsare
included inthe observable actions.
Thisoptionspecifieswhether WS-Engineer
checksthetype of interaction used over achannel
typeandtherestrictionsimposed onthe
interactionsusing the channel. If checked andan
interactionisspecifiedin WS-CDL whichisnot
valid onthe channel type thenanerroradded to
the Errorview. If unchecked, thentheaction
violationisignoredandthe model isbuiltasif
therewasnoviolation.

Below is a list of actions which can be used for quick access to analysis functions in WS-Engineer.

1. BPELAWS / WS-BPEL

Safety Model Check
Analysis

WS-Engineer | Compile State

Wie Simulation
Check Progress
Check Safety

Check Design (SPEC)
iZheck Design (BFEL)

Properties

a. Select the BPEL4WS source file in the Navigator View.
b. Right-click the file and select WS-Engineer - Check Safety.
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5.2

Progress
(Liveness)
Analysis

Ws-Enginesr ¢

Properties

Compile State

Wienw Simulation
iZheck Progress
Chack Safety

Check Design (SPEC)
Check Design (BPEL)

a. Select the BPEL4WS source file in the Navigator View.
b. Right-click the file and select WS-Engineer = Check Progress.

Check BPEL a. Select the BPEL4WS source file in the Navigator View.
b. Right-click the file and select WS-Engineer - Check Design (BPEL).

Design
Against MSC

Check MSC

Design
Against BPEL

Glossary

Term
Scenario

Implied
Scenario

Negative
Scenario

MSC

hMSC

WS-Engineer ¥

Properties

Zompile State

Wiew Simulation
Check Progress
iZheck Safety

Check Design (SPEC)
Check Design (BPEL)

a. Select the BPEL4WS source file in the Navigator View.
b. Right-click the file and select WS-Engineer = Check Design (SPEC).

and Acronyms

Definition

Link (web/papers/reports)

A brief description of events or ~ Wikipedia

series of events.

A mis-match between specified

behaviour and architecture.

An undesirable implied scenario,

from the point of view of a
stakeholder.

Message Sequence Chart

S. Uchitel, J. Kramer and J. Magee. Synthesis of
Behavorial Models from Scenarios. IEEE
Transactions on Software Engineering. Volume 29,
Number 2, February 2003.

S. Uchitel, J. Kramerand J. Magee. Negative
Scenarios for Implied Scenario Elicitation. In 10th
ACMSIGSOFT International Symposium onthe
Foundations of Software Engineering (FSE'02),
Charleston, November 2002

ITU Recommendation Z-120 04-2004, Message
Sequence Charts (MSC)

Higher-Level Message Sequence ITU Recommendation Z-120 04-2004, Message

Chart

Sequence Charts (MSC)
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bMSC

Acronym
FSP

LTSA

MSC
BPEL4WS
WS-BPEL
WS-CDL
WSDL

Basic Message Sequence Chart ITU Recommendation Z-120 04-2004, Message
Sequence Charts (MSC)

Full Title

Finite State Processes

The Labelled Transition System Analyser

Message Sequence Chart

Business Execution Language for Web Services (v1.0/1.1)

The Web Services Business Execution Language (BPEL4WS v2.0)
The Web Services Choreography Description Language

The Web Services Description Language (WSDL)
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